We recommend he latest version of the Chrome browser for all ScanPower products.


ScanPower is also compatible with Firefox but the auto product restrictions feature and browser extension will not work with Firefox.